воскресенье, 8 мая 2011 г.

ArchLinux GNOME 2.32 build failed

Сегодня ночью, пока все благочестивые люди спят в своих постелях, а все остальные шляются по ночным клубам, я пытался собрать GNOME 2.32 в виртуальной машине в ArchLinux. Причём не просто так собрать с нуля, а при наличии уже установленного GNOME 3. Зачем? Для эксперимента. Можно себе представить, что среди пользователей арчлинукса есть некий процент людей, которым гном 2 нравится сильнее, чем гном 3, или их компьютеры слабые настолько, что гном 3 работает с тормозами или не работает вовсе, и им хочется вернуть себе старый добрый гном 2.

Так вот, у меня ничего не получилось, несмотря на то, что я всё делал по инструкции. Проблема в том, что инструмент для сборки гнома jhbuild собирает пакет glib версии 2.26.2, а потом версия этой библиотеки оказывается недостаточной для сборки пакета gdk-pixbuf. Так как у меня в системе уже есть гном 3, то glib у меня уже есть достаточно свежей версии 2.28.6, и надо, наверное, как-то подменить собранное jhbuild старьё на библиотеку из окружающей системы. Я попробовал заменить симлинки, но что-то нифига не помогло, видимо, где-то надо заменять ещё что-то.

И это не считая мелких костылей вроде исправления конфигуратора, в котором жёстко прописана версия libtool-2.2*, и поэтому он считает libtool-2.4 недостаточной версией, замены симлинков на питон, и так далее :)

Комментариев нет:

Отправить комментарий

Ублюдочный Гугл поломал форму комментариев. Извините.